Exchanging a PM4 with a PM5 and logcard problems

A forum for discussing training programmes, indoor racing, things that work for you, coaching etc.

Moderator: The forum police - (nee naw)

Post Reply
Best Friend (PayPal Subscriber)
Best Friend (PayPal Subscriber)
Posts: 95
Joined: Mon Aug 03, 2015 6:46 am
I row on...: Model E with PM5
Location: Stuttgart, Germany

Exchanging a PM4 with a PM5 and logcard problems

Post by Juergie »

I decided to get serious about rowing data and analysis. It seems, that ErgData is the App that is needed to collect all the necessary data. So, I tried to connect my PM4 to my iPhone. Bought the cable but ErgData would just give me a "PM4 device is not compatible ..." :evil:

When I looked around the room in desperation, I "noticed" the PM5 on my SkiErg. No problem connecting my SkiErg to ErgData via bluetooth. Why not swap the two PMs? Hardware swap was no problem and done within minutes. When I turned the PM5 on it still showed all the SkiErg menu items. Somehow, I was under the impression, the PM would notice to which device it was connected. But a little searching on the internet brought the solution. You have to tell the PM with the ConceptUtility to what device it is connected.

So, I changed the PM4 to SkiErg, put my logcard into it and the problems begann. The PM wouldn't accept the card because there were rows saved on it. Searching the net again, found a promising solution. You have to erase all the rows then the SkiErg will reformat the card. Ok, changed the PM4 back to a rower, deleted all the data and changed it back to SkiErg. Well, I tried, that is. The process got stuck over and over again. Sometimes with a timeout message from the ConceptUtility, sometimes just wouldn't progress. As I was just about to surrender and call Concept I browsed the PM4 manual and found the factory reset option. After that I was finally able to change it to a SkiErg PM again.

But the story is not over, yet. I inserted the logcard into the PM4 and still got the above mentioned error. I was about to order a new card when I stumbled on a posting in a forum about a hidden menu item. Once you are on the second screen of the product-ID page. Press Change Units 3 times then Change Display 3 times. You enter a menu to format the logcard. But when I tried that, I still got the error message when I inserted the card and before I was able to press the format button. I figured I had to press "format" first and then exactly time the moment to insert the card. In doing so, the PM would not read the card (and then display the error) but instead go straight to formatting. Took me 5 attempts but I finally succeeded.

And now - finally - everything works as planned. But nevertheless there were quite some frustrating moments in the process.
Age: 50, Height: 186m, Weight: 84 kg
Post Reply